Creation of new certificates

Incident Report for Universign UTC

Resolved

This incident has been resolved.

We deeply apologize for the inconvenience.
Posted Jan 29, 2026 - 09:31 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2026 - 09:29 CET

Identified

The problem is identified and we are working on a fix right now.
Posted Jan 29, 2026 - 09:12 CET

Investigating

We are facing some issues. The creation of new certificates is not possible due to a technical issue.
Posted Jan 29, 2026 - 08:27 CET
This incident affected: Registration Service.